Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 24 Hours Last 24 Hours Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums Articles Articles Blog Blogs Groups Groups
  • woodauger's Avatar
    08-15-2019, 06:07 PM
    My bad - sorry. The retailer misidentified what Toyotomi included with the heater. It worked fine with the included fitting. Im putting in an L-300...
    0 replies | 38 view(s)
  • regression's Avatar
    08-12-2019, 10:04 AM
    Hello all, I have noticed blue stains in our shower and sink. I just started researching this and it sounds like the pH of our water might be too...
    0 replies | 77 view(s)
  • HeadnSouth's Avatar
    07-31-2019, 04:58 AM
    HeadnSouth replied to a thread HVAC question in Monitor Heaters
    Got a call from the installation company. They are going to eat the installation cost. They have been out a half dozen times to try to fix the issue...
    2 replies | 303 view(s)
  • akaothermick's Avatar
    07-30-2019, 10:01 PM
    akaothermick replied to a thread HVAC question in Monitor Heaters
    Sounds more like the unit is undersized for the application, or your insulation and roof ventilation system is lacking and was not taken in to...
    2 replies | 303 view(s)
  • HeadnSouth's Avatar
    07-30-2019, 07:56 AM
    Nov 2017 we had a new carrier 3 ton unit installed. It has been very hot here in Georgia and on those days the upstairs unit cannot keep the temps at...
    2 replies | 303 view(s)
  • mrcaptainbob's Avatar
    07-26-2019, 12:15 PM
    mrcaptainbob replied to a thread Updating the Site in Forum News
    72??!! You're a young man. Well, t' me you are... Stay well, HayZee....
    3 replies | 2126 view(s)
  • mrcaptainbob's Avatar
    07-25-2019, 04:31 PM
    I have a new plasma torch that runs on 240v/40a. It has a three prong plug. The unit has an additional exterior threaded terminal that, according to...
    0 replies | 158 view(s)
No More Results