Howdy all,
I recently obtained an old school Scott R 36 S that needs some work done on it. When it's turned on with speakers hooked up it only hums. The hum is unaffected by input selection or volume control. From what I've gathered this is due to bad ac filter caps (the big cans). I wanted to verify that this is a correct assumption.
When I replace the can caps, does physical size matter outside of mounting issues? I've found replacement caps online with matching farad and voltage values, but they aren't quite the same size.
Also, attached to the leads on the smaller filter cap is what looks like a smaller capacitor. When I found it, I noticed the green casing was split. I flaked off the casing and it looks like the aluminum shell underneath is in tact, so I'm not sure whether to replace it or not. Here's a pic
Click image for larger version. 

Name:	IMG_1756.jpg 
Views:	250 
Size:	142.1 KB 
ID:	2533 and one of the other side Click image for larger version. 

Name:	IMG_1757.jpg 
Views:	182 
Size:	142.5 KB 
ID:	2534

I also found a row of diodes that have black "stuff" on their leads. I don't know if they were made like this or if it's scorching and they need replaced. Here's a pic:
Click image for larger version. 

Name:	IMG_1759.jpg 
Views:	342 
Size:	148.4 KB 
ID:	2535

Well I think that about covers all the questions I have concerning this project. Any input and advice on this is greatly appreciated! And for good measure, here's a pic of the innards from the top:
Click image for larger version. 

Name:	IMG_1760.jpg 
Views:	295 
Size:	149.2 KB 
ID:	2536