Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Laser 30 smells

  1. #11
    Join Date
    Sep 2014
    Location
    Gustavus Alaska
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    ok, I might have been premature on declaring the heat element good. on my OP I think I said that the 6 screws were loose on my 2nd disassembly. and they were loose on the 3rd, and on the 4th the burn matt glue mod was cracked. here is my latest theory. the heat element was/is deformed, more then it should be. When it got/gets hot it would change shape, changing in height, cutting the upper and lower gaskets and breaking the burn matt glue. might put a heat element 20479508, and of course new upper and lower gaskets and new screws 20478090 in. if that dont fix it, its going on craigslist!

  2. #12
    Join Date
    Sep 2014
    Location
    Gustavus Alaska
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Its official!! The heat element was bent enuf that when it was heating and cooling there must have been movement in the heat chamber causing exhaust smell. Installed new gaskets and new heat element 20479508 and no more smell for two days now!!!! So if anyone is rebuilding theirs, I would stress to just replace it, because if you dont and it leaks, its a lot of time and money wasted re-buying the gaskets to build it up again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •