Results 1 to 2 of 2

Thread: Freezer starts to -18 deg then stops working...

  1. #1
    Join Date
    Aug 2017
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Freezer starts to -18 deg then stops working...

    I have a BEKO ZSA 436 freezer bought in 2005. A year ago it stopped working and I unplugged it. 2 days later I plugged it in again and it started and worked for the past year. Then I defrosted it and it started up OK to -9 deg for 10 hours or so and then stopped. I unplugged for some time and it restarted OK to -18 deg for about 30 hours then stopped.

    I now have noted that when freezer not working but plugged in over 24 hours or longer the compressor is very very hot. Unplugging, the compressor cools down over several hours and then re plugging the freezer it starts working but only for 6 or even 24 hours then stops again I suppose when the compressor overheats.


    With these symptoms what is the problem - compressor or thermostat? thanks for advice.

  2. #2
    Join Date
    Sep 2003
    Location
    Canada.
    Posts
    2,166
    Thanks
    0
    Thanked 80 Times in 73 Posts

    Exclamation Compressor overheating

    .
    The compressor overheating could be due to a failing compressor, poor voltage to the appliance (like could be caused by running it on an extension cord) or depending on the type of compressor used in it, possibly a problem with the compressor starting device and/or compressor capacitor ... if used.

    A thermostat problem could not cause the compressor to overheat.

    Dan O.
    Appliance411.com
    The Appliance Information Site

    =D~~~~~~

    .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •