Results 1 to 6 of 6

Thread: Quick Question RE MPI 2200

  1. #1
    Join Date
    Nov 2013
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Quick Question RE MPI 2200

    On a MPI 2200, if one does not have ANY voltage to the igniter pins is it only the motherboard that can be the problem?

  2. #2
    Join Date
    Mar 2011
    Posts
    108
    Thanks
    0
    Thanked 9 Times in 9 Posts
    Could be the transformer, I have both a transformer and main board on eBay.

  3. The Following User Says Thank You to msearcher For This Useful Post:

    copperlake (08-28-2017)

  4. #3
    Join Date
    Mar 2011
    Posts
    108
    Thanks
    0
    Thanked 9 Times in 9 Posts
    I can tell you that the main board was bad on a 422 heater that the igniter was good and would not work. A relay was bad.

  5. The Following User Says Thank You to msearcher For This Useful Post:

    copperlake (08-28-2017)

  6. #4
    Join Date
    Nov 2013
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by msearcher View Post
    Could be the transformer, I have both a transformer and main board on eBay.
    Thanks for the reply. Next question - is there a way to determine which is the culprit? Here's the story with this unit: it is new looking inside, the burn chamber is still black, that's how little it's been used. I'm trying to sell it but because of where I live (Alaska) Monitors are dogs on the market because no one fixes them here anymore and no one sells parts. Everyone is Toyo, me included. I've seen your parts on the bay but if I bought your board I couldn't make the difference up. For example; I just sold a perfectly running 2400 for $400.....I may just part it out on the bay unless it was something less expensive like the transformer.

    Thanks again.

  7. #5
    Join Date
    Mar 2010
    Location
    Bethel, Alaska
    Posts
    568
    Thanks
    0
    Thanked 100 Times in 98 Posts
    If the transformer was bad you would have no lights or power anywhere. You can have the board repaired by Heater PC Repair. You are correct in the fact nobody in Alaska works on Monitors and nobody has parts. In your case you are better off with a Toyo.

    Tom, Bethel Alaska

  8. The Following User Says Thank You to hawkins111 For This Useful Post:

    copperlake (08-29-2017)

  9. #6
    Join Date
    Nov 2013
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by hawkins111 View Post
    If the transformer was bad you would have no lights or power anywhere. You can have the board repaired by Heater PC Repair. You are correct in the fact nobody in Alaska works on Monitors and nobody has parts. In your case you are better off with a Toyo.

    Tom, Bethel Alaska
    Thanks for that Tom. Everything works, cycles etc., but it will not ignite. Given that I can probably get at the most 300 bucks for the unit if it was operating, I think you have made my mind for me - off to FleaBay as parts. On balance, the parts are worth more than what a repaired MB is. Too bad, because the thing is like excellent otherwise.

    Mark in Homer

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •